SharePoint: Retrieving COM class factory for component CLSID {BDEADEE2-C265-11D0-BCED-00A0C90AB50F} Failed


Had this head scratcher today which first showed up when I was trying to install a solution (wsp) to the farm and SharePoint Solution Installer told me that the solution was not already installed, which I knew it was.

Checking in central admin in solutions management I click on the solution link and I get this error. I back up and try other solution links with the same problem. I try navigating to the Operations page again, and I get this error.

A trawl of the internet suggests 2 possible fixes;

  1. Reset IIS and load Central Admin again
  2. The service accounts underwhich the app pools run as, have undergone an enforced password change, reset the passwords back, reset IIS and try again.

Thankfully the first solution fixed my problem.

 Incidently, {BDEADEE2-C265-11D0-BCED-00A0C90AB50F} is the COM CLSID of the SP.SPRequest class in OWSSVR.DLL.

Published by

Phil Harding

SharePoint Consultant, Developer, Father, Husband and Climber.

2 thoughts on “SharePoint: Retrieving COM class factory for component CLSID {BDEADEE2-C265-11D0-BCED-00A0C90AB50F} Failed

  1. Pingback: Tax Tips #2
  2. Pingback: Tax Tips #3

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s